Irish Mountain
Running Association

IMRA Payments System

Paul SmythJul 19 2021, 6:16pmHi guys,

I want to start by saying that I appreciate all the hard work and time that goes into running and the IMRA website.

While others have had problems in recent weeks paying for entries I have been fortunate enough that none of the entries I purchased in that time lead to any problems - until now.

I attempted to purchase an entry for Ballybraid. Everything went fine and after entering all the details the word Success! appeared in the box underneath the area where I entered all my personal and card details. Naturally I thought that this meant that the payment has been processed and I am now entered. However,

1. The item is still appearing in my shopping basket

2. The button on the event page is still showing 'Purchase Event Entry'

These would seem to indicate that I am not entered, in other words that my payment was successful. However as I have no feedback from the system indicating that my payment was not successful I am unwilling to put a payment through again in case my card is charged twice.
Paul SmythJul 19 2021, 6:20pmWhen I click on the Purchase Event Entry button on the event page it takes me to the Shopping Basket page where it is still showing the same 'unpaid' item for the race. The message at the top of the page says "This product is already in your basket. ...'

By the way, how long does an item remain in your basket before it gets released, returned to the pool? In other words, how long do you have before you have to pay for the item or lose it?
Caroline HarneyJul 19 2021, 8:59pmHi Guys,
I'm experiencing the same as Paul above - even down to the success message. Hadn't encountered any problems paying for event entries till this one - error message states that "transaction not permitted by merchant"

Any help appreciated
Caroline HarneyJul 19 2021, 9:01pmSuccess!
5th time lucky
Gordon WilsonJul 19 2021, 9:45pmI've tried 3 different cards and no luck with any of them. Trying to purchase entry for Glen of the Downs. Does anyone have any ideas how to proceed?
Richard NunanJul 19 2021, 10:26pmHi Paul,

Currently you are not entered. Not sure why you got success. I would need Jason to answer that one.

My recommendation would be to re-try as it worked for Ger.


Are using a mobile App . It sounds like your App needs an update, can you try this and then submit your purchase manually. Fill out all fields manually.
Mick HanneyJul 20 2021, 8:46amPaid for Ballybraid. Worked first time. BOI Debit Card on Edge Browser, filling in all details for scratch.
Paul SmythJul 20 2021, 10:33amAfter tweaking the address details I was able to get the payment to proceed.

Can we please support PayPal for payments.

@Mick: Online payments using a debit card is generally not recommended these days. Credit cards provide better protection in the event a card is compromised.
Stuart ScottJul 20 2021, 10:59amI've been successful on all attempts to date using a Revolut card. But I'd had lots of trouble in previous years using it on Amazon and the like and I suspect many of you are now experiencing the same problems. The key thing is that the address has to match the address on your bank statement 100%. Even a single letter out of place will cause it to fail. This could include using 000 as the postcode, Dublin instead of Dublin 2 (or whatever), the city repeated on two lines etc. etc. The best thing to do is to open your profile settings on the Revolut app as you enter the payment and copy it verbatim.

The same should apply to proper banks too. It's a bit harder to check but you should be able to see your address on your bank statement PDF through online banking.
Richard NunanJul 20 2021, 11:49amThanks Stuart, most helpful. It makes it more understandable why people eventually get it processed.

Will add that to the FAQ that we seem to need.
Paul O'GradyJul 20 2021, 12:14pmYes, it didn't take for me because I had typed in my address as Dun Laoghaire Co. Dublin, when my bank statement was DUN LAOGHAIRE CO DUBLIN.

Anyway, I look forward to hearing about my proposal to re-open the voucher queue. We have run plenty of Wednesday races (Brockagh 2019 being one) where we had to control numbers for one reason or another, with online entries getting a spot, and then a limited number of voucher entries, with a number of runners being left disappointed. So we do have experience of running races with controlled numbers and still taking vouchers.
Richard NunanJul 20 2021, 1:20pmHi Paul, hear you git entered.

I think you helped us answer your own question there.

Online entry has been working really well.and this way we don't have to dissapoint anyone. Another headache removed from our Team of race directors and volunteers.

We continue to look at people's proposals daily. As we outlined previously, once restrictions have been lifted we will look at the re-introduction of vouchers.
Brian FarrenJul 22 2021, 6:31pmHi. Can someone just please confirm I'm entered for the Mountain Meitheal. With current payment system I no longer get an email acknowledgement and the event shows in both my purchase history and the Shop. It no longer says "You are entered" even when logged on. Thanks Brian.
Fíona CanavanJul 23 2021, 2:17pmHello!
Has anyone had any success with a debit card associated with an address outside of Ireland (my case, UK)? Have tried three different cards including revolut and AIB to no avail. Trying to purchase IMRA membership + an entry to the Mountain Meitheal fundraiser.
Would attempting on a laptop browser make a difference at all?
Fíona CanavanJul 23 2021, 2:28pmNever mind - nothing to do with the foreign address, it was the ‘|’ between the country code and the mobile number that I was missing.
Martin CooneyJul 26 2021, 12:01pmHi IMRA,
I am trying to book Galtymore for the weekend- I have tried 3 times & won't take payment (credit card). Is there any way of resolving or can I use race vouchers on the day?
The message keeeps coming up when I try to pay is:

Your payment was not processed. Error details are shown below: undefined

Credit Card Processing Return Information:
Gp Result: 110
Gp Status: FAILURE
Gp Result Description: Transaction NOT permitted by merchant config.
Gp Transaction Id:

Please select the 'Pay Now' button again to restart the transaction..

2021-07-26 11:58:17: FAILURE
2021-07-26 11:58:13: FAILURE
2021-07-26 11:58:10: FAILURE
2021-07-26 11:58:07: FAILURE
2021-07-26 11:58:04: FAILURE
2021-07-26 11:58:01: FAILURE
2021-07-26 11:57:58: FAILURE
2021-07-26 11:57:55: FAILURE
2021-07-26 11:57:52: PENDING
Martin CooneyJul 26 2021, 12:16pmHi again IMRA,
I found my issue & got entered into Galtymore. It is the mobile phone number format... It needs to be the following: 353|861112222
There must be | (vertical line) between the country code & mobile number.
Many Thanks.
Fergus OFarrellJul 26 2021, 1:27pmHi All,
I got the same errors as others above. It turned out to be the pipe symbol | in my mobile number.
My mobile number loaded correctly initially but the auto fill function on my phone was changing it.
Before you hit pay now, just ensure your details are correct and in the correct format.
Maeve Maher-McWilliamsAug 4 2021, 11:02amHi there,

Adding my recent payment woes to this thread in case anyone can help for the next time.

I had tried probably upwards of 50 times to enter Devil's Glen between my phone and laptop over the past few days. Tried three different cards BoI and Revolut, matched my bank statement address and removed the | from the mobile number, and several other variations but no luck. I was repeatedly getting the 110 error message with "success!!" and then below payment not processed. Is there any way we can ask the payment provider to give us more info on why it was not processed? Or does anyone else have any suggestions to try next time?

Many thanks,

Conor O'FarrellAug 4 2021, 11:28amHi Maeve

With the 110 error, there are 1 of 2 things wrong (i can't recall which). And apologies if I am repeating anything said previously
1. The phone number must be in the correct format: 353|871234567. Note that the "|" character after the "353", is not a number or letter, but the "pipe" symbol. It is normally found to the left of the "Z" key, while holding down shift, on a regular keyboard. I can comment on the phone, because it is different on most phones.
2. Make sure your banking app on your phone is up to date. I think this was the problem I had when I got the error.

Note: Keep an eye out when autocompleting any boxes. I have seen it change the phone number after I have corrected it due to auto-complete, assuming I was only working on the address box.

I hope this helps.
Maeve Maher-McWilliamsAug 4 2021, 1:27pmThanks for the pointers Con! I'll keep an eye out for those and give BoI a ring to see if there is any issue at their end with the authentication.

Thanks again :)
Thomas RocheAug 4 2021, 2:28pmHi Maeve, I had the exact same problems as you. I messed around with the address. It has to be the exact same detail as your card. It took a good few attempts but got there in the end. I used a revolut card too.
Deirdre O GormanAug 4 2021, 3:02pmMaeve, I found I had to add in the 'Miss' before my name, as appears on my bank statement too, if that helps!
Maeve Maher-McWilliamsAug 4 2021, 6:04pmOh yes the Miss could have been it! I'll give myself plenty of time to enter Howth and find the version that works :) Thanks all!
Andrew HanneyAug 10 2021, 4:23pmIs there any way to stick this message to the top of the forum. Every event thread is seeing the same messages repeated over and over.